Browsium

Knowledge Base

What are the minimum system requirements for Ion?

The following minimum system specifications are required to run Browsium Ion.

Operating System Windows 7 or later
Windows Server 2008 R2 or later (for multi user terminal servers)
Browsers Internet Explorer 8, 9, 10, or 11
.NET Framework Version 3.5 SP1
Java Development Kit (JDK) and Java Runtime Environment (JRE) 32-bit JDK 7u40 or later for Ion Configuration Manager;
Client PCs requiring Java remediations only need the appropriate 32-bit or 64-bit JREs
Processor 1 GHz 32-bit (x86) or 64-bit (x64) processor
Memory 1 GB total system RAM, 2 GB RAM for multi-user terminal servers


Posted in: Ion General FAQs, Ion Knowledge Base

  • Share:  

Request Demo

Internet Explorer End of Life problems?Learn More