Browsium

Knowledge Base

What browsers work with Catalyst?

Browsium Catalyst works with Internet Explorer 8 thru 11 (IE8, IE9, IE10, and IE11), and also the recent versions of Firefox (35 and above) and Chrome (39 and above).

Posted in: Catalyst FAQs

  • Share:  

Request Demo

Internet Explorer End of Life problems?Learn More